1. 01 Nov, 2021 2 commits
  2. 23 Aug, 2021 5 commits
  3. 22 Aug, 2021 1 commit
    • scott snyder's avatar
      Update gdb to version 10.2. · 8a177601
      scott snyder authored
      The current gdb version we use (9.1) is incompatible with python 3.9,
      which is used in the lcg nightlies.  (It crashes immediately
      on startup.)   This is fixed in recent versions of gdb.
      Update gdb to version 10.2.
      8a177601
  4. 05 Aug, 2021 4 commits
  5. 29 Jul, 2021 2 commits
  6. 28 Jul, 2021 1 commit
  7. 27 Jul, 2021 2 commits
    • Attila Krasznahorkay's avatar
      Made the dictionary DEPFILE handling compatible with CMake >=3.20. · 814dc939
      Attila Krasznahorkay authored
      As it happens, CMake changed its convention for how dependency files
      should be formatted in a way that makes it impossible to generate
      these files in a way that would work with all versions of CMake. So
      now the dependency file generation is set up to work a little
      differently for different CMake versions.
      
      At the same time made sure that DEPFILE and IMPLICIT_DEPENDS would not
      be specified at the same time, as that is now apparently an error
      in CMake >=3.20.
      814dc939
    • Attila Krasznahorkay's avatar
      Prevented AtlasLCG from repeatedly extending the CMAKE_PREFIX_PATH variable. · 3d0e9ab0
      Attila Krasznahorkay authored
      Until now repeated calls to find_package(LCG...) would extend the
      CMAKE_PREFIX_PATH environment variable every time. Which could lead to
      a slight slowdown, as every find_package(...) call would need to evaluate
      a longer-than-necessary list.
      
      With this update, the code should not do this anymore.
      3d0e9ab0
  8. 26 Jul, 2021 2 commits
  9. 22 Jul, 2021 1 commit
  10. 14 Jul, 2021 3 commits
  11. 13 Jul, 2021 2 commits
  12. 08 Jul, 2021 2 commits
  13. 03 Jul, 2021 2 commits
  14. 02 Jul, 2021 5 commits
  15. 01 Jul, 2021 2 commits
  16. 30 Jun, 2021 4 commits