Commit 190558d5 authored by Carsten Burgard's avatar Carsten Burgard
Browse files

selectively triggering on cmake version number

parent f7cb2c84
......@@ -3,7 +3,9 @@ CMAKE_MINIMUM_REQUIRED(VERSION 3.4.3 FATAL_ERROR)
IF(COMMAND CMAKE_POLICY)
CMAKE_POLICY(SET CMP0003 NEW) # change linker path search behaviour
CMAKE_POLICY(SET CMP0048 NEW) # set project version
CMAKE_POLICY(SET CMP0077 NEW) # allow overwriting options with normal variables
IF(${CMAKE_VERSION} VERSION_GREATER "3.13")
CMAKE_POLICY(SET CMP0077 NEW) # allow overwriting options with normal variables
ENDIF(${CMAKE_VERSION} VERSION_GREATER)
ENDIF(COMMAND CMAKE_POLICY)
# Set default version
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment