Commit e4905a58 authored by Fabio Luchetti's avatar Fabio Luchetti
Browse files

Temporarely use obsolete 2.7 get-pip script (for python2.7)

parent c8691f24
Pipeline #2299198 skipped with stage
......@@ -45,9 +45,11 @@ RUN apt-get install -y software-properties-common \
wget \
&& apt-get clean
# Python2 and python2-pip usage is being discouraged, but we still need it for our tests
# Python2 and python2-pip usage is being discouraged, but we still need it for our tests.
# Temporarely use obsoleted 2.7 script until such patch is applied upstream on the next release.
# After that, revert to the more general https://bootstrap.pypa.io/get-pip.py
RUN apt-get install -y curl python2 \
&& curl https://bootstrap.pypa.io/get-pip.py --output get-pip.py \
&& curl https://bootstrap.pypa.io/2.7/get-pip.py --output get-pip.py \
&& python2 get-pip.py \
&& ln -s /usr/bin/python2 /usr/bin/python
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment