Commit 177fcd0e authored by Andrea Sciaba's avatar Andrea Sciaba
Browse files

Removed requirement of SL5

parent 7f2203b8
......@@ -36,11 +36,8 @@ echo "CMS software location SW_DIR=" $SW_DIR
tmpfile=`mktemp /tmp/tmp.XXXXXXXXXX`
# check for SL5
libc25=1
if ! [ -f $SW_DIR/common/cmsos ] ; then
echo "</pre><p>$SW_DIR/common/cmsos not found - force to SL5</p><pre>"
slVersion="slc5"
else
slVersion="unknown"
if [ -f $SW_DIR/common/cmsos ] ; then
osVersion=`$SW_DIR/common/cmsos`
echo "osVersion from \$SW_DIR/common/cmsos =" $osVersion
cmsarch=`$SW_DIR/common/cmsarch`
......@@ -49,25 +46,6 @@ else
fi
echo "slVersion=" $slVersion
echo "</pre>"
if ! [ -f /lib/libc-2.5.so ] ; then
echo "<p>libc 2.5 not found, not an SL5 node</p>"
libc25=0
fi
if ! [ $slVersion == "slc5" ] ; then
echo "<p>not an SL5 machine</p>"
exit $SAME_WARNING
fi
if [ $libc25 == "0" ] ; then
echo "<p>WARNING! SL5 but no libc-2.5</p>"
echo "<pre>"
echo "osVersion/slVersion =" $osVersion $slVersion
echo "ls -l /lib/libc*"
ls -l /lib/libc*
echo "</pre>"
exit $SAME_OK
fi
# this test requires SLC5 arch, currently
export SCRAM_ARCH=slc5_amd64_gcc462
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment