Commit 7f62bcfb authored by wangw's avatar wangw
Browse files

upgrade the CMSSW version 3_6_1, just can be used by SL5

parent be97929f
......@@ -6,7 +6,7 @@
# 1) environmental variables SAME_OK, SAME_WARNING and SAME_ERROR are defined
# 2) . $CMS_PATH/cmsset_default.sh has already been run
#
# $Id: CMSSW_frontier.sh,v 1.60 2010/01/21 12:32:17 wangw Exp $
# $Id: CMSSW_frontier.sh,v 1.61 2010/05/20 10:42:22 wangw Exp $
#
uname -a
date
......@@ -16,8 +16,42 @@ cat /etc/issue
#
# Choose CMSSW version
#
cmsswvsn=CMSSW_3_1_6
cmsswvsn=CMSSW_3_6_1
#
#
# check for SL5
#
libc25=1
if ! [ -f $SW_DIR/common/cmsos ] ; then
echo "$SW_DIR/common/cmsos not found - force to SL5"
slVersion="slc5"
else
osVersion=`$SW_DIR/common/cmsos`
echo "osVersion from \$SW_DIR/common/cmsos =" $osVersion
cmsarch=`$SW_DIR/common/cmsarch`
echo "scram_arch from \$SW_DIR/common/cmsarch=" $cmsarch
slVersion=`echo $cmsarch|cut -d'_' -f1`
fi
echo "slVersion=" $slVersion
if ! [ -f /lib/libc-2.5.so ] ; then
echo "libc 2.5 not found, not an SL5 node"
libc25=0
fi
if ! [ $slVersion == "slc5" ] ; then
echo "<h3> not an SL5 machine </h3>"
exit $SAME_NOTICE
fi
if [ $libc25 == "0" ] ; then
echo "<h2>ohibo' ! SL5 but no libc-2.5</h2>"
echo "osVersion/slVersion =" $osVersion $slVersion
echo "ls -l /lib/libc*"
ls -l /lib/libc*
exit $SAME_INFO
fi
# Check that environmental variable SAME_OK is set
#
if [ ! "${SAME_OK}" ]
......@@ -105,7 +139,7 @@ fi
#
# Print out version
#
printf 'version $Id: CMSSW_frontier.sh,v 1.60 2010/01/21 12:32:17 wangw Exp $\n'
printf 'version $Id: CMSSW_frontier.sh,v 1.61 2010/05/20 10:42:22 wangw Exp $\n'
#
# Set environmenal variable for FroNtier
#
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment