Commit 23b73491 authored by Diogo Filipe Tomas Guerra's avatar Diogo Filipe Tomas Guerra
Browse files

install kubernetes-dashboard from cern-metachart

Installation of kubernetes-dashboard via cern metachart
will only be available on  version 0.12.0 onwards.

DependsOn: kubernetes/automation/releases/cern-magnum!92
Closes: https://gitlab.cern.ch/kubernetes/project/-/issues/202
Change-Id: Icaff87cf6780d065d79d1965238efcab05dfe842
parent a7068a90
......@@ -9,7 +9,8 @@ do
sleep 5
done
if [ "$(echo $KUBE_DASHBOARD_ENABLED | tr '[:upper:]' '[:lower:]')" == "true" ]; then
if [ "$(echo $KUBE_DASHBOARD_ENABLED | tr '[:upper:]' '[:lower:]')" == "true" ] && \
[[ ( $(echo ${CERN_CHART_VERSION} | cut -d. -f2) -lt 12 ) ]]; then
KUBE_DASH_IMAGE="${CONTAINER_INFRA_PREFIX:-gcr.io/google_containers/}kubernetes-dashboard-amd64:${KUBE_DASHBOARD_VERSION}"
HEAPSTER_IMAGE="${CONTAINER_INFRA_PREFIX:-gcr.io/google_containers/}heapster-amd64:v1.4.2"
......
......@@ -146,6 +146,10 @@ ${NVIDIA_GPU_VALUES}
existing: ${PROMETHEUS_ADAPTER_CONFIGMAP}
cern-cvmfs-csi:
enabled: ${CVMFS_CSI_ENABLED}
kubernetes-dashboard:
enabled: ${KUBE_DASHBOARD_ENABLED}
serviceMonitor:
enabled: ${MONITORING_ENABLED}
EOF
fi
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment