Commit 4a4a62f1 authored by Andrea Valassi's avatar Andrea Valassi Committed by cdelort
Browse files

Upgrade to COOL 3.1.1

git-svn-id: https://svnweb.cern.ch/trac/lcgcool/changeset/19797 4525493e-7705-40b1-a816-d608a930855b
parent ee577589
......@@ -24,8 +24,8 @@
#ifdef COOL300
#define COOL_VERSIONINFO_RELEASE_MAJOR 3
#define COOL_VERSIONINFO_RELEASE_MINOR 1
#define COOL_VERSIONINFO_RELEASE_PATCH 0
#define COOL_VERSIONINFO_RELEASE "3.1.0"
#define COOL_VERSIONINFO_RELEASE_PATCH 1
#define COOL_VERSIONINFO_RELEASE "3.1.1"
#else
#define COOL_VERSIONINFO_RELEASE_MAJOR 2
#define COOL_VERSIONINFO_RELEASE_MINOR 9
......
......@@ -155,7 +155,8 @@ class ReferenceDbMgr:
self.svcVersion == "3.0.2" or \
self.svcVersion == "3.0.3" or \
self.svcVersion == "3.0.4" or \
self.svcVersion == "3.1.0" ):
self.svcVersion == "3.1.0" or \
self.svcVersion == "3.1.1" ):
self.svcVersion2xx = True
self.svcVersion22x = True
self.svcVersion28x = True
......
......@@ -273,9 +273,9 @@ RelationalDatabase::areReleaseAndSchemaCompatible
{
if (
#if defined(COOL300)
// This release (3.1.0) can read 3.1.x
( db_rel_version == "3.1.0" ) ||
// This release (3.1.0) can read 3.0.x
// This release (3.1.1) can read 3.1.x
( db_rel_version >= "3.1.0" && db_rel_version <= "3.1.1" ) ||
// This release (3.1.1) can read 3.0.x
( db_rel_version >= "3.0.0" && db_rel_version <= "3.0.4" ) ||
#endif
// This release (2.9.7) can read 2.9.x
......
......@@ -1240,6 +1240,7 @@ public:
openable.push_back( "3.0.3" );
openable.push_back( "3.0.4" );
openable.push_back( "3.1.0" );
openable.push_back( "3.1.1" );
#endif
// Check for failure - too old even for schema evolution
std::vector<std::string> ::iterator rel;
......
......@@ -145,6 +145,7 @@ elif ( svcVersion == "3.0.2" ): svcVersion290 = True
elif ( svcVersion == "3.0.3" ): svcVersion290 = True
elif ( svcVersion == "3.0.4" ): svcVersion290 = True
elif ( svcVersion == "3.1.0" ): svcVersion290 = True
elif ( svcVersion == "3.1.1" ): svcVersion290 = True
if ( vectorPayload and not svcVersion290 ):
print 'ERROR! Vector payload performance test not supported for service version:', svcVersion
sys.exit(-1)
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment