From c8c41611564beeee7d60c42a30f9f0207d99a3be Mon Sep 17 00:00:00 2001
From: Daniel Juarez <daniel.juarez.gonzalez@cern.ch>
Date: Mon, 30 Nov 2020 13:43:07 +0000
Subject: [PATCH] Adapt CI to latest customisations per OS on rpmci

---
 .gitlab-ci.yml | 14 +++-----------
 1 file changed, 3 insertions(+), 11 deletions(-)

diff --git a/.gitlab-ci.yml b/.gitlab-ci.yml
index 63e96a4..6a1f0db 100644
--- a/.gitlab-ci.yml
+++ b/.gitlab-ci.yml
@@ -3,21 +3,13 @@ variables:
   KOJI_TAG: 'dbclients'
   BUILD_6: 'False'
   BUILD_7: 'True'
-  BUILD_8: 'True'
+  BUILD_8: 'False'
   DIST_7: '.el7.cern'
-  DIST_8: '.el8.cern'
 
 # DO NOT MODIFY THIS
 include: 'https://gitlab.cern.ch/linuxsupport/rpmci/raw/master/rpm-ci.yml'
 # # DO NOT MODIFY THIS
 
-.rpm_deps:
+test_install7:
   before_script:
-    - if [ `rpm --eval %{dist}` == ".el8" ]; then yum-config-manager --add-repo "http://linuxsoft.cern.ch/internal/repos/dbclients8-stable/x86_64/os/"; fi
-    - yum-builddep -y *.spec
-
-.test_install:
-  before_script:
-    - if [ `rpm --eval %{dist}` == ".el8" ]; then yum-config-manager --add-repo "http://linuxsoft.cern.ch/internal/repos/dbclients8-stable/x86_64/os/"; fi
-    # test installing all binary meta packages except basiclite and compat, as these conflicts with 'basic' and 'devel'
-    - if [ `rpm --eval %{dist}` == ".el8" ]; then yum install -y --nogpgcheck `ls koji/*oracle-instantclient*x86_64.rpm |egrep -v 'basiclite|compat'`; else yum install -y --enablerepo=cernonly,cernonly-testing `ls koji/*oracle-instantclient*x86_64.rpm |egrep -v 'basiclite|compat'`; fi
+    - yum install -y --enablerepo=cernonly,cernonly-testing `ls koji/*oracle-instantclient*x86_64.rpm |egrep -v 'basiclite|compat'`
-- 
GitLab