Commit befd9e61 authored by Richard Bachmann's avatar Richard Bachmann Committed by Ivan Razumov
Browse files

Mysql dependendees fixes

parent 8d745100
......@@ -46,7 +46,7 @@ else()
LCG_external_package(ipython 5.8.0 )
LCG_external_package(libsvm 3.23 )
LCG_external_package(multiprocessing 2.6.2.1 )
LCG_external_package(mysql_python 1.2.5 )
LCG_external_package(mysql_connector_python 8.0.18 )
LCG_external_package(processing 0.52 )
LCG_external_package(jupyter_console 5.2.0 )
LCG_external_package(scikitlearn 0.20.3 )
......@@ -425,7 +425,7 @@ LCG_external_package(pytest_runner 5.1
LCG_external_package(python_dateutil 2.8.0 )
LCG_external_package(python_gitlab 1.8.0 )
LCG_external_package(pytimber 2.7.0 )
LCG_external_package(pytools 2.0 )
LCG_external_package(pytools 2019.1.1 )
LCG_external_package(pytz 2019.1 )
LCG_external_package(pywt 1.0.3 )
LCG_external_package(PyYAML 5.1 pyyaml )
......
......@@ -1415,16 +1415,31 @@ LCGPackage_Add(
BUILD_IN_SOURCE 1
)
#----autoconf-------------------------------------------------------------------
LCGPackage_Add(
autoconf
URL ${GenURL}/autoconf-${autoconf_native_version}.tar.gz
CONFIGURE_COMMAND ./configure --prefix=<INSTALL_DIR>
BUILD_IN_SOURCE 1
DEPENDS m4
)
#----automake-------------------------------------------------------------------
LCGPackage_Add(
automake
URL ${GenURL}/automake-${automake_native_version}.tar.gz
CONFIGURE_COMMAND ./configure --prefix=<INSTALL_DIR>
BUILD_IN_SOURCE 1
DEPENDS autoconf
)
#---zeromq----------------------------------------------------------------------------------------------------
LCGPackage_Add(
zeromq
URL ${GenURL}/libzmq-${zeromq_native_version}.tar.gz
CMAKE_ARGS -DCMAKE_BUILD_TYPE=${CMAKE_BUILD_TYPE}
-DCMAKE_INSTALL_PREFIX=<INSTALL_DIR>
-DWITH_PERF_TOOL=OFF
-DZMQ_BUILD_TESTS=OFF
-DWITH_LIBSODIUM=ON
DEPENDS libsodium
URL ${GenURL}/zeromq-${zeromq_native_version}.tar.gz
CONFIGURE_COMMAND ./configure --prefix=<INSTALL_DIR> --with-libsodium=yes
BUILD_IN_SOURCE 1
DEPENDS libsodium pkg_config
)
#---msgpackc----------------------------------------------------------------------------------------------------
......@@ -1720,25 +1735,6 @@ LCGPackage_Add(
DEPENDS Python
)
#----autoconf-------------------------------------------------------------------
LCGPackage_Add(
autoconf
URL ${GenURL}/autoconf-${autoconf_native_version}.tar.gz
CONFIGURE_COMMAND ./configure --prefix=<INSTALL_DIR>
BUILD_IN_SOURCE 1
DEPENDS m4
)
#----automake-------------------------------------------------------------------
LCGPackage_Add(
automake
URL ${GenURL}/automake-${automake_native_version}.tar.gz
CONFIGURE_COMMAND ./configure --prefix=<INSTALL_DIR>
BUILD_IN_SOURCE 1
DEPENDS autoconf
)
#---opencascade-----------------------------------------------------------------
LCGPackage_Add(
opencascade
......
......@@ -283,6 +283,7 @@ LCGPackage_add(
-DBINARY_TAG=${BINARY_TAG}
-DLCG_VERSION=${LCG_VERSION}
-DLCG_releases_base=${CMAKE_INSTALL_PREFIX}
-DMYSQL_INCLUDE_DIR=${mysql_home}/include
${Boost_extra_configuration}
IF Python_native_version VERSION_GREATER 3 THEN
-DLCG_python3=on
......
......@@ -326,10 +326,10 @@ LCGPackage_Add(
DEPENDS Python setuptools
)
#---mysql_python------------------------------------------------------------------------------------------------------
#---mysql_connector_python-----------------------------------------------------------------------------------------------
LCGPackage_Add(
mysql_python
URL ${GenURL}/MySQL-python-${mysql_python_native_version}.zip
mysql_connector_python
URL ${GenURL}/mysql-connector-python-${mysql_connector_python_native_version}.tar.gz
CONFIGURE_COMMAND <VOID>
BUILD_COMMAND <VOID>
INSTALL_COMMAND ${MakeSitePackagesDir}
......@@ -2221,7 +2221,7 @@ LCGPackage_Add(
pygments mistune prettytable pip PyYAML pathos pathlib2 prompt_toolkit py4j wheel CouchDB networkx decorator traitlets requests
urllib3 backports dill ipykernel ipython_genutils wcwidth ipywidgets jupyter jupyter_client jupyter_console jupyter_core MarkupSafe python_gitlab
metakernel nbconvert nbformat notebook pexpect pickleshare pox ppft pytz qtconsole simplegeneric simplejson singledispatch ${matplotlib_extra_deps}
IF NOT LCG_PYTHON_VERSION EQUAL 3 THEN 4suite multiprocessing mysql_python subprocess32 futures processing pyxml storm ENDIF
IF NOT LCG_PYTHON_VERSION EQUAL 3 THEN 4suite multiprocessing subprocess32 futures processing pyxml storm ENDIF
IF NOT LCG_OS MATCHES mac|ubuntu THEN m2crypto ENDIF
IF NOT LCG_TARGET MATCHES mac|ubuntu14|i686|ubuntu18 THEN prctl ENDIF
DEPENDS_OPT cx_oracle
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment