Commit 63b46130 authored by Pablo Panero's avatar Pablo Panero
Browse files

installation: clean non supported extras

parent 7a8571b1
......@@ -20,18 +20,9 @@ tests_require = []
invenio_db_version = '>=1.0.2,<1.2.0'
extras_require = {
# Databases
'mysql': [
'invenio-db[mysql]' + invenio_db_version,
],
'postgresql': [
'invenio-db[postgresql]' + invenio_db_version,
],
# Elasticsearch
'elasticsearch5': [
'elasticsearch>=5.0.0,<6.0.0',
'elasticsearch-dsl>=5.0.0,<6.0.0',
],
'elasticsearch6': [
'elasticsearch>=6.0.0,<6.2.0',
'elasticsearch-dsl>=6.0.0,<6.2.0',
......@@ -46,7 +37,7 @@ extras_require = {
extras_require['all'] = []
for name, reqs in extras_require.items():
if name in ('mysql', 'postgresql', 'elasticsearch6'):
if name in ('mysql', 'elasticsearch6'):
continue
extras_require['all'].extend(reqs)
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment