Commit d5525b6d authored by Pablo Panero's avatar Pablo Panero
Browse files

global: delete unnecessary files

parent c6f2992d
Installing CERNSearch requires the following services to be running:
- Elasticsearch version>=5.4.0
- PostregSQL/Mariadb/SQLite support
- Redis-server
- RabbitMQ/Another ActiveMQ implementation
Configuration is set to default values (e.g. ip:port pairs) if not, change in Config.py.
In order to start the system run the following commands (just the first time):
- invenio db init
- invenio db create
- invenio index init
- invenio index queue init (Not needed, Bulk indexing support is not yet there)
Then simply start the application with:
- invenio run \[--host 0.0.0.0\]
Note: if you do not have a valid certificate to run over SSL, make sure to have the environment variabel "FLASK_DEBUG"
set to 1.
flask
invenio-access>=1.0.0,<1.1.0
invenio-admin>=1.0.0,<1.1.0
invenio-accounts>=1.0.0,<1.1.0
invenio-app>=1.1.0,<1.2.0
invenio-base>=1.0.0,<1.1.0
invenio-config>=1.0.0,<1.1.0
invenio-db[postgresql,versioning]>=1.0.0,<1.1.0
invenio-indexer[elasticsearch6]>=1.0.0,<1.1.0
invenio-jsonschemas>=1.0.0,<1.1.0
invenio-logging>=1.0.0,<1.1.0
invenio-records-rest[elasticsearch6]>=1.3.0,<1.4.0
invenio-records[postgresql]>=1.0.0,<1.1.0
invenio-rest[cors]>=1.0.0,<1.1.0
invenio-oauthclient>=1.0.0,<1.1.0
invenio_oauth2server>=1.0.0,<1.1.0
invenio-search[elasticsearch6]>=1.0.0,<1.1.0
invenio-theme>=1.1.0,<1.2.0
ldap>=1.0.2,<1.1.0
npm>=0.1.1
python-ldap>=3.1.0,<3.2.0
raven>=6.9.0,<6.10.0
redis>=2.10.0,<3.0.0
uWSGI>=2.0.16
uwsgi-tools>=1.1.1,<1.2.0
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment