Skip to content

Updating package version requirements

Nicolas Mounet requested to merge update/fix_package_version_requirements into master

Updating package requirements in to make the tests pass locally and to avoid the expert app to crash

The packages are mypy (version >= 1.0.0), pytest-mypy (>= 0.10.3) and ipympl (>= 0.9.0).

Now all tests should pass locally (except sometimes the webapp and report_generator ones for computational time reasons, but that's ok).

Maybe in the future a minimum version should be given for all packages, and the list in requirements.txt made consistent with

Merge request reports